Difference between revisions of "WebArea/Compat/Flyspray/En"

From TuxFamilyFAQ
Jump to navigationJump to search
 
(6 intermediate revisions by 2 users not shown)
Line 2: Line 2:
 
[[WebArea/En]] > compatibility flyspray
 
[[WebArea/En]] > compatibility flyspray
  
== Before installation ==
+
* rights problem
* cgi.fix_pathinfo isn't in the correct position (in fact, the filetype .ini cannot be read)
 
so you will need to find where it is called in setup/index.php and comment out the statement that calls it.
 
(NOTE: the latest version of Flyspray does not exactly match the demonstration code snippet below)
 
  
  path setup/index.php
+
  dans feed.php
   
+
  chmod($cachefile, 02775);
//if(substr(php_sapi_name(), 0, 3) == 'cgi' && ! ini_get('cgi.fix_pathinfo')) {
 
//
 
//    die("You are using cgi or fastcgi and you have not set cgi.fix_pathinfo=1 in php.ini.
 
//        Flyspray cannot work properly without cgi.fix_pathinfo enabled, please update your configuration");
 
//}
 
  
* problem of temporary memory (impossible to write in the directory /tmp)
+
* 2008/11/12 Seems the installation wrongly says:
path include/class.flyspray.php
 
 
function get_tmp_dir()
 
{
 
  return $_SERVER["DOCUMENT_ROOT_HASH"].'/tmp';
 
...
 
  
== Post-installation ==
+
../cache      Un-writeable     
* problem of rights (at the moment I cannot do anything but test it, so I don't say that the list is complete)
+
../attachments    Un-writeable
  
path feed.php
+
I set those folders to chmod 2775 and it seems to work even if the installation setup clame it is not...
chmod($cachefile, 0664);
+
Version of flyspray: 0.9.9.5.1
 +
Also confirmed with 0.9.9.6

Latest revision as of 07:54, 9 January 2010


WebArea/En > compatibility flyspray

  • rights problem
dans feed.php
chmod($cachefile, 02775);
  • 2008/11/12 Seems the installation wrongly says:

../cache Un-writeable ../attachments Un-writeable

I set those folders to chmod 2775 and it seems to work even if the installation setup clame it is not... Version of flyspray: 0.9.9.5.1 Also confirmed with 0.9.9.6